nanogui: fltk 1.3.0 with nano-x 0.91 and nxlib 0.45


Previous by date: 11 Apr 2012 05:55:01 -0000 Re: fltk 1.3.0 with nano-x 0.91 and nxlib 0.45, Johannes Schock
Next by date: 11 Apr 2012 05:55:01 -0000 Re: fltk 1.3.0 with nano-x 0.91 and nxlib 0.45, Georg Potthast
Previous in thread: 11 Apr 2012 05:55:01 -0000 Re: fltk 1.3.0 with nano-x 0.91 and nxlib 0.45, Johannes Schock
Next in thread: 11 Apr 2012 05:55:01 -0000 Re: fltk 1.3.0 with nano-x 0.91 and nxlib 0.45, Georg Potthast

Subject: AW: [nanogui] fltk 1.3.0 with nano-x 0.91 and nxlib 0.45
From: "Johannes Schock" ####@####.####
Date: 11 Apr 2012 05:55:01 -0000
Message-Id: <E6A470EFF7BE421B88B24D9EE0395B52@ScJEntwicklung>

> I will probably try that and see how it turns out. Will provide you
> more details soon.

You should do that, because I'm quite sure you need the newest development
versions of nanox and nxlib for fltk 1.3.
AFAIK Georg Potthast managed also getting 1.3 to work. Perhaps he can tell
which versions he used.

Johannes

> -----Urspr√ľngliche Nachricht-----
> Von: Arun Ram M ####@####.####
> Gesendet: Dienstag, 10. April 2012 19:24
> An: Johannes Schock
> Betreff: Re: [nanogui] fltk 1.3.0 with nano-x 0.91 and nxlib 0.45
> 
> Hello Johannes ,
> 
> Appreciate your help.
> 
> Am trying FLTK 1.3.0 - the stable released version - released June
> 2011, which would probably be the version you tried and got running.
> 
> I have not tried it with the latest code of nxlib or microwindows
> because i saw these functions were stubbed in the latest versions also
> and so stopped with it.
> 
> I will probably try that and see how it turns out. Will provide you
> more details soon.
> 
> Thanks,
> Arun
> 
> On Tue, Apr 10, 2012 at 11:52 AM, Johannes Schock
> ####@####.#### wrote:
> >
> > Hello Arun,
> >
> > I searched all of my development nxlib folders and also found only the
> > stubs.
> > Since I already managed to have 1.3 running with nxlib there can be some
> > other reasons:
> >
> > 1. I checked the e-mail traffic I had with Greg, and I'm sure you need
> dev
> > head of nxlib and nano-x to have FLTK 1.3 running. Have you already
> tried
> > that? If not, don't read further and try that first.
> >
> > 2. Something in the X-interface of FLTK 1.3 changed during the last
> year,
> > which needs to be adressed
> >
> > 3. you have another problem, perhaps with font finding/loading, can you
> > single step through string printing code (through all projects) to find
> the
> > call which fails?
> >
> >
> > If I find time that week, I will try to set up a FLTK 1.3 test case with
> all
> > libs up to date (newest FLTK 1.3, nanox-x dev head, and nxlib dev head).
> > But I don't think I can adress this before weekend.
> >
> > Johannes Schock
> >
> >
> >
> >> -----Urspr√ľngliche Nachricht-----
> >> Von: Arun Ram M ####@####.####
> >> Gesendet: Dienstag, 10. April 2012 03:40
> >> An: Johannes Schock
> >> Betreff: Re: [nanogui] fltk 1.3.0 with nano-x 0.91 and nxlib 0.45
> >>
> >> Hello Johannes ,
> >>
> >> I checked 0.46 and the development head also, saw that these functions
> >> are only a part of the stubs. Which means that am not getting any
> >> linker errors, but text isnot being displayed in the target.
> >> I noticed that the last updated to nxlib happened back in July 2011.
> >> Would there be anymore development or any release planned soon ?
> >> Looks like i may have to replace nano-x and nxlib with something
> >> similar with which FLTK 1.3.0 is compatible.
> >> Do you have any suggestions on what could be used ?
> >>
> >> Thanks,
> >> Arun
> >>
> >>
> >> On Thu, Apr 5, 2012 at 6:50 PM, Johannes Schock
> ####@####.####
> >> wrote:
> >> > AFAIK someone (or even myself) added these two functions to the
> recent
> >> > version of NXLIB (0.46 or dev head).
> >> > But I haven't used FLTK 1.3 since more than a year. So I'm not sure
> >> about.
> >> >
> >> > Regards,
> >> > Johannes Schock
> >> >
> >> >> i was using FLTK 1.1.7 with Nano-x (microwindows 0.91) and nxlib
> 0.45
> >> >> which were
> >> >> cross compiled for an arm target.
> >> >> For localization, i was updating FLTK to 1.3.0 which provides UTF-8
> >> >> support.
> >> >> But with FLTK 1.3.0 and Nano-X 0.91 and nxlib 0.45, i was getting
> the
> >> >> following
> >> >> errors
> >> >>
> >> >> /usr/local/arm/3.4/lib/libfltk.a(utf8Input.o): In function
> >> >> `XUtf8LookupString':
> >> >> utf8Input.c:(.text+0xef8): undefined reference to `XIMOfIC'
> >> >> utf8Input.c:(.text+0xf08): undefined reference to `XLocaleOfIM'
> >> >> collect2: ld returned 1 exit status
> >> >>
> >> >> so i added stubs for those functions in stubs.c in nxlib
> >> >> This got rid of all the errors, but i found that no strings were
> being
> >> >> displayed
> >> >> on the target though the graphics were fine.
> >> >> Is this because of adding empty implementations for the functions
> above
> >> ?
> >> >>
> >> >> I'm yet to try updating Microwindows to 0.92 and nxlib to 0.46.
> Would
> >> >> these
> >> >> versions have all the required API's for FLTK 1.3.0 for UTF-8
> support ?
> >> >> Any suggestions would be helpful.
> >> >>
> >> >> Thanks,
> >> >> Arun
> >> >>
> >> >>
> >> >>
> >> >>
> >> >>
> >> >> --------------------------------------------------------------------
> -
> >> >> To unsubscribe, e-mail: ####@####.####
> >> >> For additional commands, e-mail: ####@####.####
> >> >
> >


Previous by date: 11 Apr 2012 05:55:01 -0000 Re: fltk 1.3.0 with nano-x 0.91 and nxlib 0.45, Johannes Schock
Next by date: 11 Apr 2012 05:55:01 -0000 Re: fltk 1.3.0 with nano-x 0.91 and nxlib 0.45, Georg Potthast
Previous in thread: 11 Apr 2012 05:55:01 -0000 Re: fltk 1.3.0 with nano-x 0.91 and nxlib 0.45, Johannes Schock
Next in thread: 11 Apr 2012 05:55:01 -0000 Re: fltk 1.3.0 with nano-x 0.91 and nxlib 0.45, Georg Potthast


Powered by ezmlm-browse 0.20.